<P>I was all excited to try out the new Compact Framework 2.0 stuff with Visual Studio 2005. I wrote a little web browser app and tried to deploy it to my Pocket PC and got a nice error:</P>

The current version of ActiveSync is not supported. Install the latest version from www.microsoft.com.

The latest version of ActiveSync I can find is 3.8, which is what I have installed. Is anyone else seeing this problem? Am I screwed because I had the Beta 2 bits installed on this machine at one time?